Frequently Asked Questions

Q: When using Bootstrap Tools or Bootstrap Editor I get an error in the console:
Uncaught Error: Bootstrap's JavaScript requires jQuery. jQuery must be included before Bootstrap's JavaScript.

A: This error is not an error in fact, just an issue of asynchronous inclusion of JS files inside the inner editor area (an editable document in CKEditor or TinyMCE is a kind of iframe with its own styles and scripts).
At any time, if you load Bootstrap dynamically (by any plugin for CKEditor/TinyMCE) you will receive this message. This is a part of Bootstrap (not Bootstrap Editor/Bootstrap Tools) design, and unfortunately we are unable to hide this message.
Good news are that this message will not break anything. You can just ignore it.

Q: When I use Bootstrap Tools in my control panel (admin pages) my theme becomes broken. Or I get the same with regular pages.

A: Probably your page which styles are being broken already includes Bootstrap itself, and including it again (maybe even a different version of it) messes up the styles. You need just to tell the Include CSS/JS add-on to not load Bootstrap to the global document, but keep including it into CKEditor content.

Here is a sample configuration for CKEditor:

config.jsplusInclude = {
    framework: "b4", // or your framework
    includeCssToGlobalDoc: false,
    includeJsToGlobalDoc: false
}

You can read more technical details in this article: Including Bootstrap/Foundation into CKEditor/TinyMCE