Bootstrap Table Tools
for CKEditor & TinyMCE
16 in 1
Includes products:
Bootstrap Table Tools logo
Get Bootstrap Table Tools inside
32 in 1
Bootstrap Bundle
$59
Bootstrap Table Tools logo
Get Bootstrap Table Tools inside
33 in 1
Bootstrap Full Bundle
$99

Bootstrap Include CSS & JS

Bootstrap Include CSS & JS logo

Helps you to attach Bootstrap styles to your document, so they will be displayed with appropriate sizes and positions defined by Bootstrap CSS.

ckeditor iconCKEditor 4 compatible
tinymce iconTinyMCE 4 compatible

This is the plugin for including Bootstrap framework to the CKEditor & TinyMCE. Just turn it on and all Bootstrap-specific styles will work for you inside CKEditor & TinyMCE. So after doing that you can create markup for your Bootstrap site in WYSIWYG manner. Bootstrap v. 3 will be attached.

Plugin name: jsplus_bootstrap_include
Plugin contains no buttons.

Use these values in configuration of your editor to enable the plugin.

Always turn on Bootstrap Include plugin before using any other plugins from this toolset.

Configuration

jsplus_bootstrap_include_version: Integer
Default value: 3
Available values: 3, 4
Bootstrap version to include. If you choose v. 4 to use some its new features will be unlocked.
This feature affects to all plugins in the bundle.
This is experimental feature due to Bootstrap v. 4 is in alpha state now.
jsplus_bootstrap_include_url: URL
By default Bootstrap files are loaded by this plugin with using official Bootstrap CDN. If external CDN can not be accessed from your network or you just want to specify local copy of Bootstrap, set URL of your Bootstrap folder in this option.
For example you can set this key to http://your-website.com/location/of/bootstrap/.
jsplus_bootstrap_use_theme: Boolean
Default value: true
Available values: true, false
By changing this parameter you can enable or disable including Bootstrap theme CSS file. The file will be used from folder specified in jsplus_bootstrap_include_url parameter or from official Bootstrap CDN. For Bootstrap v. 3 only
jsplus_bootstrap_include_ie_fix: Boolean
Default value: true
Available values: true, false
If this option is enabled the plugin includes additional JavaScrip files of Bootstrap for old IE versions support.
Due to these files are not included into the latest releases of Bootstrap library, they will be loaded always from CDN: https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js and https://oss.maxcdn.com/respond/1.4.2/respond.min.js. For Bootstrap v. 3 only
jsplus_bootstrap_include_in_container: Boolean
Default value: true
Available values: true, false
If your page's content is wrapped by Bootstrap's container, use this option to wrap it in the <div class="container"> tag inside editable area of the editor.
jsplus_bootstrap_include_jquery: Boolean
Default value: true
Available values: true, false
Bootstrap Include plugin can load JQuery required by some of compenents of Bootstrap framework. If you already have included JQuery library into your page turn off this feature.
This library is loaded from CDN: //ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js
jsplus_bootstrap_include_css_to_global_doc: Boolean
Default value: false
Available values: true, false
If this flat is set to true the specified CSS files will be added into global document (whole page with the editor) too.
jsplus_bootstrap_include_js_to_global_doc: Boolean
Default value: false
Available values: true, false
If this flat is set to true the specified JS files will be added into global document (whole page with the editor) too.
jsplus_bootstrap_include_preview_styles: Boolean
Default value: true
Available values: true, false
Set this option to false if you do not want to include preview styles to global document (be sure it already has Bootstrap connected!). If you set it to false without checking this you will have problems with Bootstrap styles in JS+ plugins dialogs.
jsplus_bootstrap_include_use_wet: Boolean
Default value: false
Available values: true, false
Set Bootstrap Include add-on to WET mode. WET framework is the edition of Bootstrap used by Goverment of Canada. To fully support it please set this option to true.
When WET support is enabled these files will be attached:
  • Always: css/theme.css, js/wet-boew.js instead of standard Bootstrap CSS & JS
  • If jsplus_bootstrap_include_ie_fix is enabled: css/ie8-theme.css, js/ie8-wet-boew2.js
For Bootstrap v. 3 only
jsplus_bootstrap_include_bw_icons: Boolean
Default value: false
Available values: true, false
If this option is set to true, icons of all plugins will have standard black&white icons instead of purple ones.